Subsequence |
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB |
Problem description |
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S. |
Input |
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file. |
Output |
For each the case the program has to print the result on separate line of the output file.if no answer, print 0. |
Sample Input |
2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5 |
Sample Output |
2 3 |
说明: 从 n 个数中找一个连续的子序列,使其和大于等于给定数 s , 求这个子虚列的最短长度
/////////// Sample question just for learner !!!!
#include<stdio.h>
#define MAX 100002
int a[MAX];
int main(){
int n,s,nTest,i,j,k,sum,min;
scanf("%d",&nTest);
while(nTest--){
scanf("%d %d",&n,&s);
for(i=0; i<n; i++)
scanf("%d",&a[i]);
for(j=i=k=sum=0,min=MAX; i<n; i++){
sum += a[i];
k++;
if(sum >= s){
for(; sum>=s; k--,j++)
sum -= a[j];
if(min > k+1)
min = k+1;
}
}
if(min!=MAX)
printf("%d\n",min);
else
printf("0\n");
}
return 0;
}
评论