正文

IP address2007-04-11 14:02:00

【评论】 【打印】 【字体: 】 本文链接:http://blog.pfan.cn/lingdlz/24792.html

分享到:

Problem description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:

27 26 25 24 23 22 21 20 128 64 32 16 8 4 2 1

 
Input
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

 
Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

 
Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001
 
Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
 
Problem Source
MCA 2004
 


#include <stdio.h> 

int main()
{ int j,i,n,a[10][4],m;
  char  str[40];

  scanf("%d",&j);
  for(i = 0; i < j; i ++)
 { scanf("%s",str);
   for(n = 0,m = 0; m <= 7; m ++)
  n = (str[m] - '0') + 2 * n;
   a[i][0] = n;

   for(n = 0,m = 8; m <= 15; m ++)
  n = (str[m] - '0') + 2 * n;
   a[i][1] = n;

   for(n = 0,m = 16; m <= 23; m ++)
  n = (str[m] - '0') + 2 * n;
   a[i][2] = n;
   for(n = 0,m = 24; m <= 31; m ++)
  n = (str[m] - '0') + 2 * n;
   a[i][3] = n;

 }
  for(i = 0; i < j; i ++)
 printf("%d.%d.%d.%d\n",a[i][0],a[i][1],a[i][2],a[i][3]);
  return 0;
}

阅读(2253) | 评论(0)


版权声明:编程爱好者网站为此博客服务提供商,如本文牵涉到版权问题,编程爱好者网站不承担相关责任,如有版权问题请直接与本文作者联系解决。谢谢!

评论

暂无评论
您需要登录后才能评论,请 登录 或者 注册